GCTAModelBackground and GCTAModelInstBackground names
Coming back after a while to GammaLib coding I forgot what the difference between
GCTAModelInstBackground was. After looking into the code I remembered that
GCTAModelBackground was the class developed at the 2nd coding sprint that models the background using a cube file, while
GCTAModelInstBackground was doing a similar thing, but using automatically the IRF. The second provides a clearer separation between observation realm and model realm, while the first provides full control over the background model. We likely would like to keep both.
I was thus considering whether it were not better to rename these classes to make things clearer.For example:
RE: GCTAModelBackground and GCTAModelInstBackground names - Added by Deil Christoph over 6 years ago
+1 to more explicit names.
Your new suggestions sound very good from your description, but I have to admit I haven’t used those classes or looked at the code.
I like the new names, more easy to understand.