Bug #1584

Galactic Plane Survey simulation's bug with the new ctools-0.10.0

Added by Dang Viet Tan about 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:11/26/2015
Priority:NormalDue date:
Assigned To:Knödlseder Jürgen% Done:

100%

Category:-
Target version:-
Duration:

Description

Hi, I’m Tan. I had a bug when executing the Galactic Plane Survey script you gave me (as follows) with the new ctools-0.10.0.

https://portal.cta-observatory.org/WG/PHYS/Shared%20Documents/ctools%20simulations/gps.tar.gz

It seems that the GPS is not suitable for the new version of ctools-0.10.0, because of the changes in ctmodel (I guess). Please see the attachment for details. So can you fix the GPS script ?

Thank you very much.

error-.jpg (292 KB) Dang Viet Tan, 11/26/2015 04:37 PM

gps_model_ics_1-10TeV.fits (19.7 KB) Dang Viet Tan, 01/07/2016 02:24 PM

gps_model_pi0_1-10TeV.fits (19.7 KB) Dang Viet Tan, 01/07/2016 02:25 PM

gps_model_bkg_1-10TeV.fits (19.7 KB) Dang Viet Tan, 01/07/2016 02:25 PM

gps_model_1-10TeV.fits (5.63 KB) Dang Viet Tan, 01/07/2016 02:25 PM

gps_model_cygnus_1-10TeV.fits (19.7 KB) Dang Viet Tan, 01/07/2016 02:25 PM

gps_model_pwne_1-10TeV.fits (19.7 KB) Dang Viet Tan, 01/07/2016 02:25 PM

gps_model_snrs_1-10TeV.fits (19.7 KB) Dang Viet Tan, 01/07/2016 02:25 PM

gps_model_tevcat_1-10TeV.fits (19.7 KB) Dang Viet Tan, 01/07/2016 02:25 PM

make_gps.py Magnifier (11.7 KB) Knödlseder Jürgen, 01/11/2016 08:45 PM

pi0.jpg - map with coordinates (88 KB) Dang Viet Tan, 01/15/2016 01:37 PM

ics.jpg - map with coordinates (85.4 KB) Dang Viet Tan, 01/15/2016 01:37 PM

map_pi0.fits (1.98 MB) Dang Viet Tan, 01/15/2016 01:37 PM

map_ics.fits (1.98 MB) Dang Viet Tan, 01/15/2016 01:37 PM

model_ics.xml Magnifier - executed file (691 Bytes) Dang Viet Tan, 01/15/2016 01:38 PM

model_pi0.xml Magnifier - executed file (691 Bytes) Dang Viet Tan, 01/15/2016 01:38 PM

ctobssim.py Magnifier - executed file (1.03 KB) Dang Viet Tan, 01/22/2016 11:39 AM

Error- Pi0 Ics

Recurrence

No recurrence.


Related issues

Related to ctools - Bug #1609: ctmodel no longer operates on stacked observation Closed 12/20/2015

History

#1 Updated by Dang Viet Tan almost 7 years ago

When checking the source code of ctmodel, I see that there’s no “get_obs” function in the new version (ctools.0.10.0). Maybe this is the reason why the GPS script is not executed by the ctools.10.0. Is it true ?

#2 Updated by Knödlseder Jürgen almost 7 years ago

  • Related to Bug #1609: ctmodel no longer operates on stacked observation added

#3 Updated by Knödlseder Jürgen almost 7 years ago

  • File make_gps.py added

You are right. The get_obs() method has been removed by accident. I did now put this method back, and everything seems to work on my side. See http://cta.irap.omp.eu/ctools/download.html to learn how to get the latest version from gitlab.

Please note that in the meanwhile, the GSkymap class was replaced by GSkyMap, hence the script needs to be modified. I attached the actual version of the script that works

#4 Updated by Knödlseder Jürgen almost 7 years ago

  • Status changed from New to Feedback
  • Assigned To set to Knödlseder Jürgen
  • % Done changed from 0 to 100

#5 Updated by Dang Viet Tan almost 7 years ago

Thank you for fixing it. I’ve gotten the latest version from gitlab and already installed it successfully.

I also checked your fixed file - make_gps.py but there’s only 1 line in it, and it didn’t work. So I fixed my file by replacing GSkymap by GSkyMap (only 2 places in the script). The script has worked, but the output files seem to be wrong. These files of gps_model_*.fits have just only 1 pixel (see attachment). Can you check this bug?
Thank you.

#6 Updated by Knödlseder Jürgen almost 7 years ago

  • File deleted (make_gps.py)

#7 Updated by Knödlseder Jürgen almost 7 years ago

  • File make_gps.py added

#8 Updated by Knödlseder Jürgen almost 7 years ago

  • File deleted (make_gps.py)

#9 Updated by Knödlseder Jürgen almost 7 years ago

There was another regression in addition to the removal of the get_obs() method (see #1609), sorry for that. It should now be fixed (just get the latest code from gitlab using the devel branch).

I also updated the script that works on my side.

Can you check that everything is also fine on your side?

#10 Updated by Dang Viet Tan almost 7 years ago

I’ve already checked it on my side and the results seems good. Thank you very much.

By the way, I still have problem with simulating ics and pi0 map by ctobssim. It didn’t work even with the new version of ctools. When I check your map (in the directory “models” in gps.tar.gz), I found that the maps inconsistent with Galactic coordinates (see attachment). Maybe that’s why I cannot execute ctobssim by using your XML and FITS files (attachment). Can you check this problem for me ?

#11 Updated by Dang Viet Tan almost 7 years ago

I’m sorry that I was wrong about the coordinates mentioned above. The maps are fine.

But I still cannot execute GPS by ctobssim (it was aborted immediately). Can you check it one more time and show me the output file of ics and pi0? Thank you.

#12 Updated by Knödlseder Jürgen almost 7 years ago

Dang Viet Tan wrote:

I’m sorry that I was wrong about the coordinates mentioned above. The maps are fine.

But I still cannot execute GPS by ctobssim (it was aborted immediately). Can you check it one more time and show me the output file of ics and pi0? Thank you.

Could you provide me with the command sequence that you try to execute so that I can reproduce it here and follow this up?

#13 Updated by Dang Viet Tan almost 7 years ago

Yes, you can see the executed file as attachment (ctobssim.py). For easy, I just specify only one point on Galactic plane.

I’m trying to simulate some celestial objects on Galactic plane now. I have a presentation at the Astronomical Society in this March, so it’s very helpful if you can support me fast. Thank you a lot.

#14 Updated by Knödlseder Jürgen almost 7 years ago

I looked into this and there was indeed still a bug in a GammaLib class (GModelSpatialDiffuseMap) for maps that were not normalized, i.e. the ones we use for the KSP simulation.

I fixed the bug and you can check out the latest code from gitlab.

I hope this solves all you problems.

Thanks for your feedback, it’s really useful in finding problems.

#15 Updated by Dang Viet Tan almost 7 years ago

I’ve downloaded and checked the latest code by my side. Everything looks good. :)
Thank you very much for your fast response. It’s very helpful.

#16 Updated by Knödlseder Jürgen almost 7 years ago

  • Status changed from Feedback to Closed

Great. I close this bug issue now.

Also available in: Atom PDF